Business account billing information temporarily unavailable
Incident Report for Exosite
Resolved
This incident has been resolved.
Posted Nov 12, 2024 - 17:59 UTC
Monitoring
Upstream has addressed the issue. Billing information continues to load successfully at this time.
Posted Nov 12, 2024 - 17:17 UTC
Identified
We have identified an issue with our upstream billing provider resulting in billing information being temporarily unavailable.
Posted Nov 12, 2024 - 17:03 UTC
This incident affected: Exosite Account & Billing Management Application.