Slow response on Portals
Incident Report for Exosite
Resolved
We believe that we have mitigated the slow response problem on Portals.
Posted Apr 24, 2017 - 17:03 UTC
Investigating
Portals pages are loading very slowly. We are investigating the problem.
Posted Apr 24, 2017 - 14:38 UTC