Account & Billing Management interface availability

Incident Report for Exosite

Resolved

This incident has been resolved.
Posted Jun 08, 2025 - 23:52 UTC

Monitoring

We are seeing improved availability from our systems to our upstream provider at this time.
Posted Jun 08, 2025 - 23:12 UTC

Identified

We've identified an issue with our upstream billing provider that is currently impacting availability of Account & Billing Management.

Device connectivity and IoT application processing are not impacted.
Posted Jun 08, 2025 - 19:15 UTC
This incident affected: Exosite Account & Billing Management Application.